Frequently Asked Questions

The website says my browser isnt supported. What browser should I use?

Nutaku games run best on the latest versions of Chrome, Firefox, or Internet Explorer. You can update your browser by selecting the appropriate link from the choices above.

Back to Support